yafaray 0.1.5 linux 64bit builds lack JPG support

Project:YafaRay
Version:development
Component:Blender Exporter
Category:bug report
Priority:normal
Assigned:David Bluecame
Status:closed
Description

Hello I am French sorry for my English problem on texture .jpg
Version of yafaray 0.1.5
Blender 2.67 Linux mint Maya 64 bits

ERROR: TextureMapper: texture '0x7f8effb1f770' does not exist!
ERROR: NodeMaterial: No shader node was constructed by plugin 'texture_mapper'!
ERROR: Glossy: loadNodes() failed!
INFO: Environment: Added Material 'feuille2--9223363271048184381' (glossy)!
INFO: Exporter: Creating Material: "feuille1--9223363271048184445"
INFO: NodeMaterial: Added ShaderNode 'diff_layer0'! (0x7f8f05016080)
ERROR: TextureMapper: texture '0x7f8ef17507c0' does not exist!
ERROR: NodeMaterial: No shader node was constructed by plugin 'texture_mapper'!
ERROR: Glossy: loadNodes() failed!



Comments

#1

This is a know problem, derived from using an JPEG libs version in Linux Blender build.

#2

if you install the driver for 32bit compatability it should work:

sudo apt-get install libjpeg62:i386



let me know if that helps.

#3

it helps indeed, it worked here. Thanks Sanjurjo !

#4

Title:yafaray 0.1.5» yafaray 0.1.5 linux 64bit builds lack JPG support

#5

Assigned to:jeff» David Bluecame

Although this was supposedly fixed acording to the comments here, there are still inconsistencies with versions of libraries. I'm currently investigating dependencies, etc, to see if we can get better portability.

#6

Status:active» ready to commit

Hello,

Due to the fast release cycle of the Blender builds, the diversity of distros, etc, I believe we should use a "generic" linux build similar to the official "generic" linux builds for glibc2.11.

So, I've created such "generic" linux builds, adapted to work with the official Blender.org Linux builds of a yafaray experimental version.

You have the information and download links here for both 32bit and 64 versions:

http://www.yafaray.org/community/forum/viewtopic.php?p=31050#p31050

 

I've tested them against blender 2.74 from Blender.org official Linux downloads, in Debian 7.8.0 32bit and 64bits and also in Ubuntu 14.10 32bit and 64bits and they seem to be working.

In my tests, I had no problems at all with the jpeg, png, hdr, tiff and exr images I used as textures. So I will consider this as "ready for commit", and if these work then probably the official YafaRay builds will be generated the same way, thus not needing anymore to be in the repositories of the distros and hopefully not having problems with library incompatibilities (crossing fingers!)

Please test and let us know how they work for different distros, but please remember to use them with the Blender 2.74 official downloads from blender.org

#7

Status:ready to commit» closed

This is solved in the latest builds, see: http://www.yafaray.org/community/forum/viewforum.php?f=12

So, closing for now. If somebody has other problems with the new builds we will open new entries in the bug tracker.