Rendering with 2 or more volumetric objects results in no light affecting on the objects

Project:YafaRay
Component:YafaRay Core
Category:bug report
Priority:normal
Assigned:David Bluecame
Status:closed
Description

When trying to render 2 or more volumetric objects, the volumetrics gets darker (no one lamp affects volumetrics)

Check the file below

Original scene : volumetrics white (affected by the light)

now duplicate the cube (shift+d) and move next to the original cube and try to render again (should result in black volumetrics)

AttachmentSize
Volumetrics.blend256.8 KB

Comments

#1

this topic is briefly discussed in the forum with example images

http://www.yafaray.org/community/forum/viewtopic.php?f=13&t=2492

#2

This problem remains in  YafaRay 0.1.2 beta / Blender 2.5 exporter (August 2011)

#3

Assigned to:Anonymous» David Bluecame
Status:active» needs review

Hello,

I have sent a pull request to solve this problem, see:

https://github.com/YafaRay/Core/pull/94

 

However, I think this needs review before merging into Master. I think what I've done makes sense (it solves the problem mentioned here), but I wonder if there was a reason for the way this was designed that way... Input from the developers would be welcome here...

 

This problem can be tested with the attached scene. Just enable/disable cube.000, .001 or .002 and see how the attenuation changes.

AttachmentSize
Volumetrics_bug.blend 536.22 KB

#4

Status:needs review» fixed

Fixed in YafaRay-E (Experimental) v1.0.0

 

For more information, see:  http://www.yafaray.org/community/forum/viewtopic.php?f=12&t=5117

 

If you still have this issue with the new version please let us know.

#5

Status:fixed» closed

Automatically closed -- issue fixed for 2 weeks with no activity.