View topic - compiling on Ubuntu error

compiling on Ubuntu error

Users-contributed CVS development builds. Post here your questions about compiling the source code.

compiling on Ubuntu error

Post Tue Sep 13, 2016 6:15 pm

I started compiling again on Ubuntu (16.04), but I have opencv errors.

fatal error: opencv2/photo.hpp: No such file or directory

libopencv-photo-dev is installed, but photo.hpp is located at /usr/include/opencv2/photo/photo.hpp

I don't know where to add the library path in, I assume, CmakeCache.txt

Help..... :)
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: compiling on Ubuntu error

Post Tue Sep 20, 2016 2:04 pm

Hello,

Sorry, I've been "out" for a while due some personal matters. I hope to be able to resume working on YafaRay soon.

I'm not sure, I would have to check if there is any CMake setting for OpenCV include directories.

In the mean time, perhaps this could help?

http://stackoverflow.com/questions/3528 ... -0-install

Best regards!
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Re: compiling on Ubuntu error

Post Tue Sep 20, 2016 3:08 pm

Hi, thanks.

Yes, that works, mostly.

Adding the symlink allows it to compile, but then there is a linking error related to yafaray-xml - http://pasteall.org/80543

Changing set(WITH_XML_LOADER ON) to set(WITH_XML_LOADER OFF) in the user config resolves the linking error and it is rendering. I'll have to test to check everything is working :)

I didn't compile for many, many months, should Yafaray xml be disabled now? It is kinda of an old UserConfig.txt; the previous saved version is more than three years old, but the default for the xml loader seems to be on :/

EDIT - Oh wait, no it isn't rendering, there was another version :(
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: compiling on Ubuntu error

Post Tue Sep 20, 2016 3:39 pm

Hello,

I'm preparing the builds of the new version v3.1.0 and doing some checks. I will upload them soon!
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Re: compiling on Ubuntu error

Post Tue Sep 20, 2016 6:01 pm

Hello again.

v3.1.0 released! :-)

http://www.yafaray.org/community/forum/ ... 84&start=0

I hope it works for you. Please let me know if you have any issues with it.
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Re: compiling on Ubuntu error

Post Tue Sep 20, 2016 6:43 pm

David Bluecame wrote:Hello again.

v3.1.0 released! :-)

http://www.yafaray.org/community/forum/ ... 84&start=0

I hope it works for you.


It does :)

Thanks
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm


Return to Testing Builds



Who is online

Users browsing this forum: No registered users and 4 guests

cron