View topic - Yafaray, Archlinux, libs and a problem :S

Yafaray, Archlinux, libs and a problem :S

General questions related with the YafaRay Project, 3D computer graphics and about this site.

Yafaray, Archlinux, libs and a problem :S

Post Thu Jun 10, 2010 11:02 pm

Hi, Sorry by my bad english 1º =)

I use blender and yafaray in archlinux, but yafaray can't open the image jpg, png, bmp and more used for texture and UV-Mapping

this is the msj of the terminal when try to reload the preview of a material X whit a texture "image" the image is a png but is igual whit all map bit format:

=== kd-tree stats (0s) ===
used/allocated kd-tree nodes: 1/256 (0.390625%)
primitives in tree: 1
interior nodes: 0 / leaf nodes: 1 (empty: 0 = 0%)
leaf prims: 1 (1x prims in tree, leaf size:1)
=> 1 prims per non-empty leaf
leaves due to depth limit/bad splits: 0/0
clipped triangles: 0 (0 bad clips, 0 null clips)
scene_t::update(): new scene bound is
(-2.0042, -2.0042, -2.0042), (2.0042, 2.0042, 2.0042)
rendering 1 passes, min 1 samples, 1 per additional pass (max 1 total)
[################################################################] (done)
overall rendertime: 0.054398s
flushing imageFilm buffer
clearing data...
delete scene...done
** imageFilter stats: unlocked adds: 9216 locked adds: 784
INFO: Adding Texture: Tex type IMAGE: /mnt/Deposito/Hamoody/Texturas/cuadritos.png
Loading image file /mnt/Deposito/Hamoody/Texturas/cuadritos.png
libpng warning: Application was compiled with png.h from libpng-1.4.2
libpng warning: Application is running with png.c from libpng-1.2.38
libpng error: Incompatible libpng version in application and library
png_create_read_struct failed
unknown file extension, testing format...
unknown format!
Could not load image
error: no texture was constructed by plugin 'image'!
INFO: Adding Material: Material
added ShaderNode 'diff_layer0'! (0xadb22c0)
warning: no element type given; assuming shader node
[ERROR]: texture '0xb108de8' does not exist![ERROR]: no shader node was constructed by plugin 'texture_mapper'!
creating nodes failed!
added Material 'Material' (shinydiffusemat)!
added object 'Sphere1' (sphere)!
added Light 'LAMP1' (pointlight)!
added Light 'LAMP2' (pointlight)!
added Background 'world_background' (sunsky)!
added camera 'cam' (perspective)!
added Integrator 'default'!
added Integrator 'volintegr'!
scene mode:1
starting build of kd-tree (1 prims, cr:0.8 eb:0.33)
getting triangle bounds...done!
starting recursive build...



If some body cant helpme I gifthe a Ice Cream :P
DiegoSg
 
Posts: 3
Joined: Thu Jun 10, 2010 10:48 pm

Re: Yafaray, Archlinux, libs and a problem :S

Post Fri Jun 11, 2010 1:22 pm

It looks like you have a version mismatch.

The libpng on your machine is older than the version used to build yafaray.

You could maybe -
Update the libpng version on your machine, or
Add the later version to your machine and link to it, or
Build Yafaray from source


I should add, I am not a developer and there may be a more elegant solution :)
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Yafaray, Archlinux, libs and a problem :S

Post Fri Jun 11, 2010 2:37 pm

stoneage wrote:It looks like you have a version mismatch.

The libpng on your machine is older than the version used to build yafaray.

You could maybe -
Update the libpng version on your machine, or
Add the later version to your machine and link to it, or
Build Yafaray from source


I should add, I am not a developer and there may be a more elegant solution :)



No man, I have installed the last version of the libpng (1.4.x if I remembre fine) this is de parafigm maybe the yafaray-svg (installed with yaourt) have the old version but I dont know change this... Some help?
DiegoSg
 
Posts: 3
Joined: Thu Jun 10, 2010 10:48 pm

Solut¡on Yafaray, Archlinux, libs and a problem :S

Post Sat Jun 12, 2010 6:12 pm

Ok, I have the solution... is very easy,

1º) uninstall blender and all the dependecies $ pacman -Rc blender
2º) install blender2.4-svn with yaourt $ yaourt -S blender2.4-svn
3º) install yafaray-svn with yaourt to $ yaourt -S yafaray-svn


TX AUR =)
DiegoSg
 
Posts: 3
Joined: Thu Jun 10, 2010 10:48 pm

Re: Solut¡on Yafaray, Archlinux, libs and a problem :S

Post Mon Jun 14, 2010 9:29 am

DiegoSg wrote:Ok, I have the solution... is very easy,

1º) uninstall blender and all the dependecies $ pacman -Rc blender
2º) install blender2.4-svn with yaourt $ yaourt -S blender2.4-svn
3º) install yafaray-svn with yaourt to $ yaourt -S yafaray-svn


TX AUR =)


thanx for mentioning the solution. it works here too :)
rebegin
 
Posts: 3
Joined: Sat Apr 12, 2008 1:23 pm
Location: Debrecen, Hungary


Return to News & Discussion



Who is online

Users browsing this forum: No registered users and 5 guests