View topic - yafaray keeps segfaulting (ubuntu lucid 64bit)

yafaray keeps segfaulting (ubuntu lucid 64bit)

General questions related with the YafaRay Project, 3D computer graphics and about this site.

yafaray keeps segfaulting (ubuntu lucid 64bit)

Post Thu Apr 22, 2010 11:59 am

Hi all,

I'm having trouble rendering my outdoor scene, the render keeps segfaulting, taking blender with it in its fall (something I'd like to see differently, btw)

First, I thought it was the qt window, because rendering to file (with darktide) worked well, but this started to crash when I added more geometry to the scene (lowpoly people).

In the end I rendered the outdoor scene with luxrender, which looked *stunning* with good render times (<15 min for a 1200x600 WIP).
But I want to use yafaray (animation).

My question is, what can *I* do to figure out what is causing the crash, is it coming from yafaray, is it the OS (lucid lynx is still beta), is it the build ( I used both pre-compiled and homebrew, both have the same behavior), is it maybe faulty memory ?

I heard somebody in a durian movie talk about "profiling" with regards to a crashing blender 2.5 render. Is this something I could do ... and how exactly.


Any Ideas ?
wizzleteet
 
Posts: 5
Joined: Thu Feb 08, 2007 3:36 pm

Re: yafaray keeps segfaulting (ubuntu lucid 64bit)

Post Tue Apr 27, 2010 8:12 pm

Lens Shift !

Don't use blender's lens shift, use "architect" camera.

I'm not quite sure why this is changed, I am quite happy with the lens shift feature, it works very well for me.

Also, closing the yafaray window by clicking the (X) button kills everything and drops you to your desktop, file-> close does what it promises, it only closes the window.
wizzleteet
 
Posts: 5
Joined: Thu Feb 08, 2007 3:36 pm


Return to News & Discussion



Who is online

Users browsing this forum: No registered users and 3 guests

cron