View topic - Blender 2.7

Blender 2.7

Users-contributed CVS development builds. Post here your questions about compiling the source code.

Re: Blender 2.7

Post Sat Jun 07, 2014 9:08 pm

About Ubuntu 14.04, I'm still using 12.04... I want to install 14.04 in a second partition just to check first but maybe in a couple of months

If you're used to the Unity interface you won't have much trouble adapting, but do expect some issues with all the library updates included in this version.
13.04 was heaven for me, everything was compatible, everything compiled fine, everything ran and got along with the rest of the system perfectly...PARADISE! hahahahha :D But the unity desktop was giving me a bit of a headache so I switched to Linux Mint 16, which is based on Ubuntu 13.04, and I loved it. Now I'm back with Ubuntu and with the help of humble souls like yours the future looks bright ;)

regards,
Alvaro F. Celis
User avatar
afecelis
 
Posts: 384
Joined: Fri Aug 19, 2005 1:17 am
Location: Colombia

Re: Blender 2.7

Post Mon Jun 09, 2014 2:12 am

afecelis wrote:I'm getting a segfault-core dump error caused by openexr's 'libIlmImf-2_1.so.21' and I haven't found a way to fix it.


Someone here had a compilation error regarding ilmbase. It prevented Blender building, but maybe it is related?
http://blenderartists.org/forum/showthr ... mBase-quot

Klopp@blenderartists.org wrote:EDIT :
Okay, I had different version of Ilmbase apparently which cause the problems... I deleted all versions in package manager (libilmbase) and it solved everything
User avatar
stoneage
 
Posts: 1240
Joined: Sun Dec 23, 2007 1:06 pm

Re: Blender 2.7

Post Tue Jun 10, 2014 12:15 am

Thanks Stoneage. I'll look into it ;)
User avatar
afecelis
 
Posts: 384
Joined: Fri Aug 19, 2005 1:17 am
Location: Colombia

Re: Blender 2.7

Post Wed Jun 11, 2014 1:34 pm

Code: Select all
Someone here had a compilation error regarding ilmbase. It prevented Blender building, but maybe it is related?


I removed system's ilmbase libraries, as the link suggests, and tried everything from scratch again, using blender's install_deps script, but now I'm getting errors building openimage, and lots of weird stuff with boost's pthread options, arrrrgggghhhhhh! Ubuntu 14.04 has been the first version in which blender doesn't compile right out of the box! They have truly messed up everything library-wise for the sake of having the latest-and-greatest available in this version. :( This is so frustrating.

I did find a ppa repo which compiles fresh builds of blender and this one has the jpeg support I require for textures to load properly in yafaray, so I quit! My blender-compiling days are over. I'll stick to the ppa binaries and the the version of Yafaray I was able to compile win Condar's help. ;)

thanks for all the help, like the say, "if it's working fine, don't mess with it", so if I got a working blender+yafaray combo I'd better stay put, lol!" :D

regards,

Alvaro F. Celis
User avatar
afecelis
 
Posts: 384
Joined: Fri Aug 19, 2005 1:17 am
Location: Colombia

Re: Blender 2.7

Post Wed Jun 11, 2014 3:44 pm

Don't feel frustrated.
I am on the same team...
I can't build blender since 2.69...
I use PPA too.
It works. :D
Arquitecto can be contacted here:
Arquitectos
Arquitecto
 
Posts: 249
Joined: Mon Jul 27, 2009 8:42 am
Location: Portugal

Re: Blender 2.7

Post Wed Jun 11, 2014 10:12 pm

Arquitecto, you almost wrote that in Haiku! ;)
Thanks for accompanying me in my pain and sorrow :D
I hope things get fixed sometime soon in Ubuntu for us to be able to compile our beloved Blender once more, like in the old days of ancient and magnificent tradition.
And yup, meanwhile the ppa installation is the best!

regards,
Alvaro F. Celis

Ps. Love your work, your renders are great!
User avatar
afecelis
 
Posts: 384
Joined: Fri Aug 19, 2005 1:17 am
Location: Colombia

Re: Blender 2.7

Post Tue Jun 24, 2014 12:00 am

Funnily, if you just run "python scons/scons.py" in blender's source folder, blender compiles and runs fine, only without cycles and other fancy addons, but this version works great with the yafaray version I also compiled ;)
User avatar
afecelis
 
Posts: 384
Joined: Fri Aug 19, 2005 1:17 am
Location: Colombia

Re: Blender 2.7

Post Wed Jul 02, 2014 1:35 pm

Hello, for my job I was used to work with blender 2.49b and yafaray 011 but I wanted to work with a newer version of blender still with yafaray. Searching on the web I've read that yafaray 015 could work with blender 2.66 so I've downloaded them both. No problem to install blender and i've installed yafaray as was shown in the video but when I try to enable yafaray by checking the box I've the following errors messages :

"The procedure entry point vsnprintf could not be located in the dynamic link library msvcrt.dll"

after clicking ok
"This application failed to start because libstdc++-6.dll was not found. Re-installing the application may fix this problem"

after clicking ok again,
"This application failed to start because libyafaraycore.dll was not found. Re-installing the application may fix this problem"

I tried to copy the yafaray file directly in the blender/2.66/scripts/addons as I've read somewhere on this forum but it's still the same. I'm using Windows XP-32 and all the *.dll required (msvcrt.dll, libstdc++-6.dll and libyafaraycore.dll) are installed.

I can choose "yafaray render" in blender but if I try to change the setting for a lamp or a material I've the following error message :
"This application failed to start because libstdc++-6.dll was not found. Re-installing the application may fix this problem"
and it's always the same even if I click on ok (loop), so I've to do "ctrl+alt+del" to close blender.

what have I done wrong ?

Could someone please teach me the right way to install yafaray (maybe a step by step)?

Sorry for my bad english (french was not in the list)
Fango
 
Posts: 3
Joined: Thu Apr 17, 2014 11:53 am

Re: Blender 2.7

Post Wed Jul 23, 2014 10:37 am

Yafaray doesn't work with Blender 2.71 (Windows)

Yafaray project is dead ?
kenanaybati
 
Posts: 34
Joined: Sun Mar 03, 2013 3:34 pm
Location: Istanbul

Re: Blender 2.7

Post Sun Jul 27, 2014 10:00 pm

kenanaybati wrote:Yafaray doesn't work with Blender 2.71 (Windows)

In other post you did show some problems between Yafaray and Blender 2.7/2.71

http://www.yafaray.org/community/forum/viewtopic.php?f=12&t=5043

but thats because python libs compatibility issues: You are using a blender version built with Python 3.4 and a Yafaray version built with Python 3.3. Blender and yafaray NEEDS to be built with the same python version.

I'm using right now the Official Blender 2.71 from Blender.org, on Linux with my own version of Yafaray, built with the same Python version as Blender.... and it works fine :). For Windows is the same

kenanaybati wrote:....
Yafaray project is dead ?


No. Yafaray is not dead, but we only have one active developer for now ;)

"Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men."

User avatar
condar
 
Posts: 771
Joined: Sun Apr 12, 2009 2:41 am

Re: Blender 2.7

Post Wed Jul 30, 2014 11:29 am

Thanks for your reply
How can I re-built YafaRay with the latest Python version ?
kenanaybati
 
Posts: 34
Joined: Sun Mar 03, 2013 3:34 pm
Location: Istanbul

Re: Blender 2.7

Post Tue Aug 19, 2014 11:23 am

Don't mean to be pushy, but for those who are not able to compile anything for Windows (or Linux), will there ever be an official update?
Blender 2.73
Yafaray 1.5.0
Windows 7/8.1 x64
Gilu
 
Posts: 7
Joined: Wed Apr 30, 2014 6:23 am
Location: Switzerland

Re: Blender 2.7

Post Tue Aug 19, 2014 5:54 pm

kenanaybati
 
Posts: 34
Joined: Sun Mar 03, 2013 3:34 pm
Location: Istanbul

Re: Blender 2.7

Post Wed Aug 20, 2014 4:55 am

kenanaybati wrote:Try it.


I did and I liked it! :mrgreen:
Thank you very, very much!

So far, Yafaray works with Blender 2.71!

EDIT:
Ok! Now I got some black dots in my render which weren't there before (with Blender 2.70 and Yafaray 1.5.0). See file attached.
Attachments
Büro1.jpg
Office with black dots
Blender 2.73
Yafaray 1.5.0
Windows 7/8.1 x64
Gilu
 
Posts: 7
Joined: Wed Apr 30, 2014 6:23 am
Location: Switzerland

Re: Blender 2.7

Post Tue Sep 09, 2014 5:29 am

Hello guys, i just noticed that yafary is not working on blender 2.71, i'll be looking in to the issue and trying to release some win 32/64 builds soon.

I hope that can be tomorrow or by wednesday

Greetings from Mexico
Just Vampires Playing To Be Mortals...
---------{--<@
User avatar
DarkTide
 
Posts: 124
Joined: Mon Jan 17, 2005 11:57 pm
Location: México

PreviousNext

Return to Testing Builds



Who is online

Users browsing this forum: No registered users and 3 guests

cron