View topic - STILL... Yafaray 0.1.1 and Ubuntu 9.10 Problem (SOLVED)

STILL... Yafaray 0.1.1 and Ubuntu 9.10 Problem (SOLVED)

Users-contributed CVS development builds. Post here your questions about compiling the source code.

STILL... Yafaray 0.1.1 and Ubuntu 9.10 Problem (SOLVED)

Post Mon Nov 02, 2009 12:08 pm

Hi,
I'm a user of windows making my way into switching to Ubuntu, but sometimes I can´t understand what happens in Ubuntu. In my laptop I had Ubuntu 9.04 with Blender 2.49b and Yafaray 0.1.1 working perfect but now that I did a fresh installation of Ubuntu 9.10, Yafaray doesn't work.

I don´t remember how I get it to work on Ubuntu 9.04, but I know that the deb package from Blender.org is python 2.5 and Yafaray is 2.6 but the tar. file is 2.6. Now I have a version of Blender for python 2.5(I don't know where in the file system) installed that doesn't work with yafaray and a folder with a Blender for python 2.6 but I can't get it to recognize the installed Yafaray.

I don't know how clear this is but for a newbie at Linux sometimes is hard to get things to work together.
Many users just want to install things and get to work.
I don´t know but maybe there should be a deb package to a Blender that work with python 2.6 or a Yafaray for both python or something that install both at same time. :?

Can someone help me?

Thanks in advance.
Last edited by camara on Mon Nov 09, 2009 9:47 pm, edited 4 times in total.
camara
 
Posts: 21
Joined: Wed Sep 03, 2008 10:25 am
Location: Portugal

Re: Yafaray 0.1.1 and Ubuntu 9.10 Problem

Post Mon Nov 02, 2009 5:28 pm

If you install Blender from a .deb it makes a .blender directory in your home folder which contains Blender's scripts directory (.blender/scripts).
This is Blender's default scripts directory, and presumably where Yafaray has installed its python files. It could be all you need to do is open your Python 2.6 Blender, and, in User Preferences change the default scripts path to the folder with Yafaray's python exporter in it.

In your file manager you can view hidden files with View -> Hidden files (or CTRL+H).

When you launch Blender for Python 2.6 in a Terminal does it say it found Python?
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Yafaray 0.1.1 and Ubuntu 9.10 Problem

Post Tue Nov 03, 2009 10:07 am

OK, it works! Thanks, Stoneage.
After your post I went and started to experiment. Blender on the terminal gave me python 2.5, but I did a search on the file system and find a blender file in /usr/bin/ that I replace with the same file from the Blender with python 2.6. This gave me from terminal that Blender found python 2.6. The other thing I need to do was to copy the file yafaray_ui.py from /.blender/sripts/blender were it was created in only /.blender/scripts.

Maybe not the right way to get it to work, but if it works its fine by me!
camara
 
Posts: 21
Joined: Wed Sep 03, 2008 10:25 am
Location: Portugal

Re: Yafaray 0.1.1 and Ubuntu 9.10 Problem (SOLVED)

Post Wed Nov 04, 2009 9:56 pm

Bad news, after closing Ubuntu and restating it worked two times then Blender it just crashed and keep crashing.
Running from terminal this is what it gives:

eduardo@eduardo-laptop:~$ blender
Compiled with Python version 2.6.4.
Checking for installed Python... got it!
YafaRay 0.1.1
~yafrayInterface_t() delete scene...delete environment...done
YafaRay 0.1.1
~yafrayInterface_t() delete scene...delete environment...done
YafaRay 0.1.1
Loading plugins ...
Registered material type 'shinydiffusemat'
Registered background type 'textureback'
Registered background type 'constant'
Registered light type 'spherelight'
Registered material type 'glass'
Registered material type 'mirror'
Registered material type 'null'
Registered material type 'rough_glass'
Registered volumeregion type 'UniformVolume'
Registered shader node type 'texture_mapper'
Registered shader node type 'value'
Registered shader node type 'mix'
Registered shader node type 'layer'
Registered shader node type 'vcolor'
Registered light type 'sunlight'
Registered material type 'glossy'
Registered volumeregion type 'SkyVolume'
Registered background type 'sunsky'
Registered integrator type 'bidirectional'
Registered integrator type 'pathtracing'
Registered material type 'blend_mat'
Registered background type 'darksky'
Registered texture type 'clouds'
Registered texture type 'marble'
Registered texture type 'wood'
Registered texture type 'voronoi'
Registered texture type 'musgrave'
Registered texture type 'distorted_noise'
Registered texture type 'rgb_cube'
Registered texture type 'image'
Registered light type 'directional'
Registered volumetric handler type 'beer'
Registered volumetric handler type 'sss'
Registered background type 'gradientback'
Registered integrator type 'directlighting'
Registered light type 'arealight'
Registered light type 'meshlight'
Registered light type 'bg_portal_light'
Registered integrator type 'SkyIntegrator'
Registered integrator type 'EmissionIntegrator'
Registered light type 'spotlight'
Registered integrator type 'DebugIntegrator'
Registered material type 'coated_glossy'
Registered integrator type 'photonmapping'
Registered material type 'light_mat'
Registered material type 'mask_mat'
Registered integrator type 'SingleScatterIntegrator'
Registered volumeregion type 'ExpDensityVolume'
Registered integrator type 'none'
Registered light type 'pointlight'
Registered volumeregion type 'NoiseVolume'
YafaRay 0.1.1
Loading plugins ...
Registered material type 'shinydiffusemat'
Registered background type 'textureback'
Registered background type 'constant'
Registered light type 'spherelight'
Registered material type 'glass'
Registered material type 'mirror'
Registered material type 'null'
Registered material type 'rough_glass'
Registered volumeregion type 'UniformVolume'
Registered shader node type 'texture_mapper'
Registered shader node type 'value'
Registered shader node type 'mix'
Registered shader node type 'layer'
Registered shader node type 'vcolor'
Registered light type 'sunlight'
Registered material type 'glossy'
Registered volumeregion type 'SkyVolume'
Registered background type 'sunsky'
Registered integrator type 'bidirectional'
Registered integrator type 'pathtracing'
Registered material type 'blend_mat'
Registered background type 'darksky'
Registered texture type 'clouds'
Registered texture type 'marble'
Registered texture type 'wood'
Registered texture type 'voronoi'
Registered texture type 'musgrave'
Registered texture type 'distorted_noise'
Registered texture type 'rgb_cube'
Registered texture type 'image'
Registered light type 'directional'
Registered volumetric handler type 'beer'
Registered volumetric handler type 'sss'
Registered background type 'gradientback'
Registered integrator type 'directlighting'
Registered light type 'arealight'
Registered light type 'meshlight'
Registered light type 'bg_portal_light'
Registered integrator type 'SkyIntegrator'
Registered integrator type 'EmissionIntegrator'
Registered light type 'spotlight'
Registered integrator type 'DebugIntegrator'
Registered material type 'coated_glossy'
Registered integrator type 'photonmapping'
Registered material type 'light_mat'
Registered material type 'mask_mat'
Registered integrator type 'SingleScatterIntegrator'
Registered volumeregion type 'ExpDensityVolume'
Registered integrator type 'none'
Registered light type 'pointlight'
Registered volumeregion type 'NoiseVolume'
INFO: Adding Textures
INFO: Adding Materials
INFO: Adding Material: defaultMat
added Material 'defaultMat' (shinydiffusemat)!
INFO: Adding Material: Material
added Material 'Material' (shinydiffusemat)!
INFO: Adding Lights
INFO: Adding Lamp: Lamp type: Point
added Light 'Lamp' (pointlight)!
INFO: Adding Objects
INFO: Adding Camera
added camera 'cam' (perspective)!
INFO: Adding Object: Cube
INFO: Adding World, type: Single Color
added Background 'world_background' (constant)!
INFO: Adding Render
INFO: Adding Integrator: Direct lighting
added Integrator 'default'!
INFO: Adding Volume Integrator: None
added Integrator 'volintegr'!
creating new QApplication
Falha de segmentação
eduardo@eduardo-laptop:~$

I out of ideas. :cry:
camara
 
Posts: 21
Joined: Wed Sep 03, 2008 10:25 am
Location: Portugal

Re: STILL... Yafaray 0.1.1 and Ubuntu 9.10 Problem

Post Wed Nov 04, 2009 10:03 pm

camara, run qtconfig and select plastique as theme that might help you avoid the crash

Greetings from Mexico...

DarkTide
Just Vampires Playing To Be Mortals...
---------{--<@
User avatar
DarkTide
 
Posts: 124
Joined: Mon Jan 17, 2005 11:57 pm
Location: México

Re: STILL... Yafaray 0.1.1 and Ubuntu 9.10 Problem

Post Mon Nov 09, 2009 9:46 pm

Thanks! It worked! :D
Back on track!
camara
 
Posts: 21
Joined: Wed Sep 03, 2008 10:25 am
Location: Portugal


Return to Testing Builds



Who is online

Users browsing this forum: No registered users and 1 guest

cron