View topic - Yafaray on Ubuntu 8.04

Yafaray on Ubuntu 8.04

Users-contributed CVS development builds. Post here your questions about compiling the source code.

Yafaray on Ubuntu 8.04

Post Wed Aug 12, 2009 5:46 pm

Hi!
Does anybody use yafaray on 8.04? Is it possible? Is there a way to get a .deb package for 8.04?
Thanks,

Attila
att
 
Posts: 89
Joined: Wed Aug 12, 2009 5:36 pm

Re: Yafaray on Ubuntu 8.04

Post Wed Aug 12, 2009 6:48 pm

Try here, I think the links are still working:-
http://www.yafaray.org/download/yafaray010

Bear in mind though, it is r315(0.1.0) and will not have all the features of the current release.(0.1.1)
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Yafaray on Ubuntu 8.04

Post Wed Aug 12, 2009 7:48 pm

That's sounds great, thanks!
What about the 0.1.1? It should be installed from source?
Unfortunatelly my skills aren't enough for that ... :-\

Attila

Ps.: Dowloaded, it's OK with Hardy+Blender2.48, thanks!
att
 
Posts: 89
Joined: Wed Aug 12, 2009 5:36 pm

Re: Yafaray on Ubuntu 8.04

Post Thu Aug 13, 2009 12:17 am

att wrote:That's sounds great, thanks!
What about the 0.1.1? It should be installed from source?


You could do it that way, it keeps it up to date...

The one on the download page for Jaunty is 0.1.1, but you would possibly need some updated dependencies that probably aren't easily available for Hardy.

Building from source isn't too difficult. There is a script available that does most of the hard work for you. You can get it here if you want to take a look at it. Be sure to download version 2.0 or later:-
http://www.yafaray.org/community/forum/ ... &start=105
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Yafaray on Ubuntu 8.04

Post Fri Aug 14, 2009 8:04 am

stoneage wrote:
att wrote:That's sounds great, thanks!
What about the 0.1.1? It should be installed from source?


You could do it that way, it keeps it up to date...

The one on the download page for Jaunty is 0.1.1, but you would possibly need some updated dependencies that probably aren't easily available for Hardy.

Building from source isn't too difficult. There is a script available that does most of the hard work for you. You can get it here if you want to take a look at it. Be sure to download version 2.0 or later:-
http://www.yafaray.org/community/forum/ ... &start=105


Thanks a lot, i'll try ...
att
 
Posts: 89
Joined: Wed Aug 12, 2009 5:36 pm

Re: Yafaray on Ubuntu 8.04

Post Mon Aug 24, 2009 4:25 pm

So!
I really tried, but I had problems with blender compilation (I got yasm, but still was some errors...) so i tried with the method i found on the download page, and it worked well! so now i have a blender 2.48 + the yafaray, and working. (I spent about a week to get all the deppendent stuff, after that it was easy ...)
att
 
Posts: 89
Joined: Wed Aug 12, 2009 5:36 pm

Re: Yafaray on Ubuntu 8.04

Post Mon Aug 24, 2009 8:26 pm

That is great news.....

Did you build Blender from the script as well? If you run the script again it will update them both, so whenever there is something added to the svn repository you can build the latest version.
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Yafaray on Ubuntu 8.04

Post Tue Aug 25, 2009 7:49 am

Yeah, that's sounds great and it would be good to have the newest blender version ... The yafaray compilation went OK with the script but with blender first I got message 'couse of the yasm o.6 was missing. I installed that (from source yeah!) but after that something went wrong again. I may try it again and post the message I got. (I am not at that machine right now...)
Thanks for the help!
att
 
Posts: 89
Joined: Wed Aug 12, 2009 5:36 pm

Re: Yafaray on Ubuntu 8.04

Post Tue Aug 25, 2009 5:41 pm

It probably isn't appropriate to post Blender problems here, but if you pm it to me I will take a look. I can't guarantee I'll know the solution but give it a shot....

www.blenderartists.org is a very good Blender forum, but you probably know that already.
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Yafaray on Ubuntu 8.04

Post Fri Aug 28, 2009 7:23 pm

att wrote:Hi!
Does anybody use yafaray on 8.04? Is it possible? Is there a way to get a .deb package for 8.04?
Thanks,

Attila

I work on Ubuntu 8.04 exclusively and Yafaray works without problems for me.All you need is to follow the instructions from the Download page...

http://www.yafaray.org/development/build

"Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men."

User avatar
condar
 
Posts: 771
Joined: Sun Apr 12, 2009 2:41 am


Return to Testing Builds



Who is online

Users browsing this forum: No registered users and 3 guests

cron