View topic - Blender 2.49a for Win is built with Python 2.6!

Blender 2.49a for Win is built with Python 2.6!

Users-contributed CVS development builds. Post here your questions about compiling the source code.

Blender 2.49a for Win is built with Python 2.6!

Post Mon Jun 22, 2009 10:44 am

I updated Blender on my WinXP machine, and I found that it was built with Python 2.6, while Linux users can choose the Python version.
So I downgraded Blender to 2.49 to keep Yafaray to run correctly.
What is the future for Blender+Python+Yafaray?
User avatar
MarcoA
 
Posts: 390
Joined: Mon Aug 27, 2007 2:19 pm
Location: Italy

Re: Blender 2.49a for Win is built with Python 2.6!

Post Mon Jun 22, 2009 4:44 pm

I still compile blender SVN against python 2.54 so it works fine with current yafaray, you can grab it here:
http://files.wildspad.com/afecelis/blen ... n32-vc.zip
Built with scons+msvc, you'll need the MS visualc runtimes installed.
It should work fine with the latest 0.1.1 rc2:
http://yafaray.darkstyle.com.mx/YafaRay ... -win32.exe
User avatar
afecelis
 
Posts: 384
Joined: Fri Aug 19, 2005 1:17 am
Location: Colombia

Re: Blender 2.49a for Win is built with Python 2.6!

Post Tue Jun 23, 2009 3:44 am

That will work, but 'downgrade' isn't really a real 'fix' for the problem.

Most Blenderheads are not going to do that.

Is there some way of getting Yafaray to 'ignore' the installed Python 2.6 and just use 2.5? I have the same problem and all was good until I installed Python 2.6 and Blender 2.49a. So 2.5 is installed, its just that Yafaray is taking the 2.6 Python as the latest version and working with that.

I'm not a coder, but is it checking for the 'latest' python in a windows registry entry? Can we just get it to look for 2.5 and ignore other versions?
User avatar
teamonster
 
Posts: 64
Joined: Wed May 21, 2008 2:06 pm
Location: Out of his Mind

Re: Blender 2.49a for Win is built with Python 2.6!

Post Tue Jun 23, 2009 10:58 am

In what way is that a 'downgrade'? It is the latest SVN Blender working with the current version of Yafaray.

Building with Python 2.5 instead of 2.6 surely doesn't remove any Blender or Yafaray functions?


(It is also pretty straightforward to build them yourself with your own choice of Python. :D )
User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Blender 2.49a for Win is built with Python 2.6!

Post Tue Jun 23, 2009 2:44 pm

Yeah, but most people aren't going to look this thread up, or download and reinstall Blender. They are going to expect it to work with the one released by the Blender Institute. No matter how much people argue that that you can make it work by downloading stuff from various places, most people are not going to know or find out how to do that.

It should work with the version of Blender that ships.
User avatar
teamonster
 
Posts: 64
Joined: Wed May 21, 2008 2:06 pm
Location: Out of his Mind

Re: Blender 2.49a for Win is built with Python 2.6!

Post Tue Jun 23, 2009 4:43 pm

User avatar
stoneage
 
Posts: 1241
Joined: Sun Dec 23, 2007 1:06 pm

Re: Blender 2.49a for Win is built with Python 2.6!

Post Sun Jun 28, 2009 3:59 am

I installed it and it works a dream. I commented in the other thread, I haven't done any real tests but it seems a lot faster.
User avatar
teamonster
 
Posts: 64
Joined: Wed May 21, 2008 2:06 pm
Location: Out of his Mind


Return to Testing Builds



Who is online

Users browsing this forum: No registered users and 2 guests

cron