View topic - Recent Blender Exporter fails to Render

Recent Blender Exporter fails to Render

Users-contributed CVS development builds. Post here your questions about compiling the source code.

Re: Recent Blender Exporter fails to Render

Post Wed Jan 03, 2018 9:34 pm

Not sure I mentioned being "impossible". I did say it was failing, at least recently. I have successfully compiled from source since 2012. Actually, i'd be happy to overcome the situation if I could. Apart from the following warnings, Yafaray compiles successfully.

Code: Select all
src/bindings/CMakeFiles/_yafqt.dir/build.make:75: warning: overriding recipe for target 'src/bindings/yafaray_v3_interface.py'
src/bindings/CMakeFiles/_yafqt.dir/build.make:65: warning: ignoring old recipe for target 'src/bindings/yafaray_v3_interface.py'
src/bindings/CMakeFiles/_yafqt.dir/build.make:75: warning: overriding recipe for target 'src/bindings/yafaray_v3_interface.py'
src/bindings/CMakeFiles/_yafqt.dir/build.make:65: warning: ignoring old recipe for target 'src/bindings/yafaray_v3_interface.py'


Then after installation, trying to render the default scene (cube) in Blender, yields the following:
Code: Select all
Traceback (most recent call last):

  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/io/yaf_export.py", line 430, in update
    self.exportScene()
  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/io/yaf_export.py", line 89, in exportScene
    self.yaf_object.createCameras()
  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/io/yaf_object.py", line 61, in createCameras
    if bpy.types.YAFA_V3_RENDER.useViewToRender or not render.use_multiview:
AttributeError: 'RNA_Types' object has no attribute 'YAFA_V3_RENDER'

location: <unknown location>:-1

location: <unknown location>:-1
[22:05:32] ERROR: Environment: Specify a Camera!!


An RNA_Types attribute error may indicate compatibility issues between Yafaray_v3 and the Blender I compiled from git source. So, there may *not* be any unusual bug, except spotting the changes in Blender's code that inspires associated updates in Yafaray. More grease to your elbows as you integrate Embree into yafaray.
User avatar
twohot
 
Posts: 18
Joined: Mon Jan 10, 2011 1:51 am

Re: Recent Blender Exporter fails to Render

Post Sat Jan 06, 2018 10:14 pm

Hello,

I've installed fedora 28 rawhide and proceeded to build Blender and YafaRay. I've got the same error you reported, so I will start investigating why is this happening. I will keep you informed of my progress.

Thank you for your feedback!
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Re: Recent Blender Exporter fails to Render

Post Sun Jan 07, 2018 2:42 am

Thanks a lot! You're amazing
User avatar
twohot
 
Posts: 18
Joined: Mon Jan 10, 2011 1:51 am

Re: Recent Blender Exporter fails to Render

Post Sun Jan 07, 2018 10:09 am

Hello,

I have updated the Blender Exporter code. I hope this solves it:
https://github.com/YafaRay/Blender-Exporter/commit/6ced457dd9ba25729847193b2f8b787bab749345

It looks like Blender has made some changes to their RNA and types code in their development 2.79 git code, causing the YafaRay 3D view render to crash.

I have tried to find an alternative way to achieve the same functionality using global variables. Please let me know if this works for you or if you still have problems.

Best regards!
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Re: Recent Blender Exporter fails to Render

Post Sun Jan 07, 2018 6:58 pm

It works!

Yes ... You are amazing!
Thanks a lot :D :D :D :D
User avatar
twohot
 
Posts: 18
Joined: Mon Jan 10, 2011 1:51 am

Re: Recent Blender Exporter fails to Render

Post Sun Jan 07, 2018 7:01 pm

Glad to hear, thank you for reporting this problem! :-)
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Re: Recent Blender Exporter fails to Render

Post Tue Jan 16, 2018 11:51 pm

OOPS!

This showed up today:
Code: Select all
Traceback (most recent call last):
  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/bin/yafaray_v3_interface.py", line 14, in swig_import_helper
    return importlib.import_module(mname)
  File "/opt/blender/2.79/python/lib64/python3.6/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 994, in _gcd_import
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 658, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 571, in module_from_spec
  File "<frozen importlib._bootstrap_external>", line 922, in create_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
ImportError: libopencv_photo.so.3.2: cannot open shared object file: No such file or directory

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/opt/blender/2.79/scripts/modules/addon_utils.py", line 331, in enable
    mod = __import__(module_name)
  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/__init__.py", line 66, in <module>
    from . import io
  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/io/__init__.py", line 21, in <module>
    import yafaray_v3_interface
  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/bin/yafaray_v3_interface.py", line 17, in <module>
    _yafaray_v3_interface = swig_import_helper()
  File "/home/twohot/.config/blender/2.79/scripts/addons/yafaray_v3/bin/yafaray_v3_interface.py", line 16, in swig_import_helper
    return importlib.import_module('_yafaray_v3_interface')
  File "/opt/blender/2.79/python/lib64/python3.6/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
ImportError: libopencv_photo.so.3.2: cannot open shared object file: No such file or directory
User avatar
twohot
 
Posts: 18
Joined: Mon Jan 10, 2011 1:51 am

Re: Recent Blender Exporter fails to Render

Post Wed Jan 17, 2018 4:52 am

Hi,

That is thetypical problem with rolling distros such as rawhide, they are too unstable. You probably upgraded opencv and the lib names change. Try rebuilding YafaRay now.

My advice is to use a stable distro like Fedora 27 and upgrade every year or so. Rawhide is not recommended for normal use as far as I know.
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Re: Recent Blender Exporter fails to Render

Post Wed Jan 17, 2018 6:10 pm

*DONE*

Its working again
Thanks

See? That's the fun in using rolling releases ... the disruption is the fun. Its exciting following developments and seeing how things affect each other. Call it a sort of early testing.
User avatar
twohot
 
Posts: 18
Joined: Mon Jan 10, 2011 1:51 am

Re: Recent Blender Exporter fails to Render

Post Wed Jan 17, 2018 9:31 pm

twohot wrote:*DONE*

Its working again
Thanks

See? That's the fun in using rolling releases ... the disruption is the fun. Its exciting following developments and seeing how things affect each other. Call it a sort of early testing.


You have a point there, thank you for your early testing! :-)
User avatar
David Bluecame
 
Posts: 460
Joined: Mon Jan 21, 2013 12:42 pm
Location: Spain

Previous

Return to Testing Builds



Who is online

Users browsing this forum: No registered users and 3 guests